John's Arcade and Arcade Outsiders Forum - Classic Arcade and Pinball Collecting and Restoring Discussion Forum - RETRO MAME - Nintendo Vs Forum
July 27, 2017, 10:49:34 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Welcome to the John's Arcade Forum. Glad you made it! Smiley
 
   Home   Help Search Calendar Login Register  
Pages: [1]
  Print  
Author Topic: Backwards Frogger  (Read 155 times)
0 Members and 1 Guest are viewing this topic.
VGAGuy
Newbie
*
Offline Offline

Posts: 2


View Profile
« on: June 25, 2017, 07:14:17 PM »

My Frogger board has a problem.
The game works fine except the sprites are backwards and some are misplaced, everything is going in the right direction, it's just backwards.
I have no idea what is causing this issue, the CPU, ROM, and 74LS201N RAM is good, no idea about the 2114s, I have no way to test them right now and I was using someone  else's test bench to test the board as I don't have my own yet. 

Any help is appreciated.
« Last Edit: June 25, 2017, 07:18:09 PM by VGAGuy » Logged
Cody.Hines0921
Newbie
*
Offline Offline

Posts: 6


View Profile
« Reply #1 on: June 27, 2017, 09:41:36 PM »

well i personally have never fixed a arcade game little lone owned one or anything i am actually just looking at getting into this hobby of collecting and fixing i am only 16 years old tho but i think it would be a good learning lesson and a rewarding hobby ANYWAYS the most advice i can offer being a complete and total noob to the topic would be try replaceing all the roms/ram with fresh stuff if this doesnt solve the problem troubleshoot the monitor have you tried adjusting any pots on the monitor to see if this resolves anything? this sounds like a very weird issue indeed and since i am a complete and total noob to the hobby i have no clue this is the best advice i can give at this point but u could try asking around on klov or somthing if none of this fixes it if you have watched johns pacman cabaret restore videos i can remember/recall when he first got the game up and running in a playable state that he had ms pacman and pacman sprites glitched together due to overlapping roms or somthing so this may be a place to start? have you tried downloading a fresh set of frogger roms from a reliable source and burning them to the eprom things and putting them onto the pcb  and loading it up? if you plan to go this route i recommend this site for any and every rom or emulator needs https://www.emuparadise.me/M.A.M.E._-_Multiple_Arcade_Machine_Emulator_ROMs/Frogger/12989 i use this site all the time for mame roms to just play some games in mame for fun that link there is a link to a frogger rom as your issue is with a frogger i apologize if this doesnt resolve or fix anything
Logged
DeLuSioNaL29
Newbie
*
Offline Offline

Posts: 45



View Profile
« Reply #2 on: July 07, 2017, 01:08:31 PM »

We need pics to see what you're talking about.  But it sounds to me that you have the monitor upside down.   Grin
Logged
VGAGuy
Newbie
*
Offline Offline

Posts: 2


View Profile
« Reply #3 on: July 12, 2017, 01:52:56 PM »

The monitor is fine.  Since no one had this problem with a Frogger board, I looked for Galaxian boards with this problem(since they share the same video hardware) and found that someone had this problem and fixed it by replacing the octal transceiver that talks to the VRAM.

Repair log(not mine): http://wiki.arcadeotaku.com/w/Galaxian_Repair_Logs


Hopefully replacing that chip will fix the problem.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.21 | SMF © 2015, Simple Machines